www-Umleitung geht plötzlich nicht

  • Jetzt anmelden. Es dauert nur 2 Minuten und ist kostenlos!

Werbung

Jetzt auf elektrisches Fahren umstellen, Umwelt schonen und 1.500km kostenlosen Strom von Tesla bekommen. https://ts.la/carsten15473.

StephanBo

Mitglied
28 Januar 2012
170
0
16
Code:
RewriteCond %{HTTP_HOST} ^www.meineseite.de [NC]
RewriteRule (.*) http://meineseite.de [L,R=301]
Hatte eigentlich nie Probleme mit obigen Code, jetzt nach einem Serverwechsel sagt er mir bei einem www-Aufruf die DNS-Adresse ist nicht gefunden und leitet mich nicht auf die http:/ weiter (diese geht). Ich scheine gerade blind zu sein. Sieht hier jemand einen Fehler?
 
Zuletzt von einem Moderator bearbeitet:

scbawik

Senior HTML'ler
14 Juli 2011
2.542
448
83
Code:
RewriteCond %{HTTP_HOST} ^www.meineseite.de [NC]
RewriteRule (.*) http://meineseite.de [L,R=301]
Hatte eigentlich nie Probleme mit obigen Code, jetzt nach einem Serverwechsel sagt er mir bei einem www-Aufruf die DNS-Adresse ist nicht gefunden und leitet mich nicht auf die http:/ weiter (diese geht). Ich scheine gerade blind zu sein. Sieht hier jemand einen Fehler?
DNS hat nix damit zu tun.
Sieh dir lieber mal die Nameserver-Einstellungen an (Wshl. im Server Interface deines Providers zu finden).
 

Spicelab

Mod | ZENmechanic
Team
Moderator
27 November 2015
1.669
319
83
Goa
Code:
RewriteCond %{HTTP_HOST} ^www.meineseite.de [NC]
RewriteRule (.*) http://meineseite.de [L,R=301]
Sieht hier jemand einen Fehler?
Wenn diese Schreibweise bislang funktioniert hat, bin ich mir nicht sicher, ob darin ein Fehler enthalten ist.

Meine RewriteCond / -Rule lauten seit jeher syntaktisch ein wenig anders:
Code:
RewriteEngine on # optionale Angabe, falls bei Dir nicht (mehr) vorhanden
RewriteCond %{HTTP_HOST} ^www\.meineseite\.de$ [NC]
RewriteRule ^(.*)$ http://meineseite.de/$1 [R=301]
 

StephanBo

Mitglied
28 Januar 2012
170
0
16
@scbawik: mache ich! Danke.

@Spicelab: Also auch mit deiner Syntax geht es nicht! RewriteEngine on hatte ich natürlich schon ganz zu beginn gesetzt. Aber mit deiner Syntax ist was ganz anderes jetzt passiert: Es ist extrem schneller geworden! Aber so was von schneller. Ist in meinem Code irgendwas geschrieben, was die Seite ausgebremst hat?
 
Werbung: