Nach Update Phpmyadmin nicht mehr aufrufbar.

  • Jetzt anmelden. Es dauert nur 2 Minuten und ist kostenlos!

m.scatello

Aktives Mitglied
15 Februar 2017
875
91
28
Dann installiere den Apache und MariaDB trotzdem als Dienst und stelle dann unter Dienste bei beiden den Starttyp auf manuell. Um die Dienste dann zu starten, wenn du sie brauchst, nimmst du dieses Batchfile:
Code:
@echo off
net start mariadb
net start apache2.4
pause
und führst es einmal als Administrator aus.
 

Industriemeister

Mitglied
24 Februar 2011
469
1
18
www.heisse-fantasien.de
Ich habe die Dienste
  • Apache_install_as serviece.bat
  • MariaDB_install_as _service.bat
  • Apache_Start_service.bat
  • MariaDB_Start_service.bat
  • PHP_change_version.bat
nun mit Administrator-Rechten ausgeführt.
Doch wenn ich die PHP-Version auswählen möchte bekomme ich folgende Meldung

Der Name für den Dienst ist ungültig.
Sie erhalte weitere Hilfe, wenn sie NET HELPMSG 2185 eingeben.
Doch NET HELPMSG 2185 kann ich nicht eingeben. Sobald ich eine Taste drücke ist das Eingabefenster weg.

Was mache ich nur falsch?
Muss ich die die Dienste nicht im Task-Manger finden können?
 

m.scatello

Aktives Mitglied
15 Februar 2017
875
91
28
Entferne mal in den Dateien
  • Apache_install_as serviece.bat
  • MariaDB_install_as _service.bat
jeweils die ersten Zeile oder kommentiere sie mit einem rem
Und als letzte Zeile schreibst du
pasue
Danach beide nochmal mit Admin-Rechten ausführen

<edit>
Gerade nochmal die Dateien durchgesehen, in Apache_install_as serviece.bat ist in der Zeile

C:\webserver\webserver\Apache-2.4.27\bin\httpd -k install

ein webserver\ zuviel
</edit>
 

m.scatello

Aktives Mitglied
15 Februar 2017
875
91
28
Hier nochmal die Batch-Files:
Code:
@ECHO off
REM
REM Apache_Install_as_service.bat
REM
echo "Installiere Apache 2.4 als Dienst"
C:\webserver\Apache-2.4.27\bin\httpd -k install
pause
Code:
@ECHO off
REM
REM MariaDB_Install_as_service.bat
REM
echo "Installiere MariaDB als Dienst"
C:\webserver\mariadb-10.2.8-winx64\bin\mysqld -install MariaDB --defaults-file C:\webserver\mariadb-10.2.8-winx64\my-large.ini
pause
Code:
@ECHO off
REM
REM Apache_Start_service.bat
REM
echo "Starte Apache-Dienst"
net start apache2.4
pause
Code:
@ECHO off
REM
REM MariaDB_Start_service.bat
REM
echo "Starte MariaDB-Dienst"
net start MariaDB
pause
Code:
@ECHO off
REM
REM Apache_Stop_service.bat
REM
echo "Stoppe Apache-Dienst"
net stop apache2.4
pause
Code:
@ECHO off
REM
REM MariaDB_Stop_service.bat
REM
echo "Stoppe MariaDB"
net stop MariaDB
pause
Code:
@ECHO off
REM
REM Apache_Uninstall_service.bat
REM
echo "Deinstalliere Apache-Dienst"
net stop apache2.4
C:\webserver\Apache-2.4.27\bin\httpd -k uninstall
pause
Code:
@ECHO off
REM
REM MariaDB_Uninstall_service.bat
REM
echo "Deinstalliere MariaDB-Dienst"
net stop MariaDB
C:\webserver\mariadb-10.2.8-winx64\bin\mysqld -uninstall MariaDB
pause
 

Industriemeister

Mitglied
24 Februar 2011
469
1
18
www.heisse-fantasien.de
Nun hat sich bei dem ausführen von Apache_install_as service.bat etwas geändert.
Folgende Fehlermeldung erhalte ich

Windows Fenster
Das Programm kann nicht gestartet werden, da vcrunttime140.dll auf dem Computer fehlt. Installieren sie das Programm erneut. um das Problem zu beheben.

was muss ich nun machen?
 

Industriemeister

Mitglied
24 Februar 2011
469
1
18
www.heisse-fantasien.de
Vielen Dank,

nun läuft der Apache.
Doch vermutlich muss ich beim dbconnect.php den ich in index.php (startseite) auf rufen etwas ändern
dbconnect.php Code:

// Datenbank OFFLINE
mysql_connect("127.0.0.1","root","") or die ("keine Verbindung moeglich");
mysql_select_db("heisse-fantasien") or die ("Die Datenbank existiert nicht");
?>

Fehler:
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in C:\webserver\htdocs\heisse-fantasien\dbconnect.php:6 Stack trace: #0 C:\webserver\htdocs\heisse-fantasien\index.php(3): include() #1 {main} thrown in C:\webserver\htdocs\heisse-fantasien\dbconnect.php on line 6

Zeile 6 = Zeile mysql_connect...

wie muss ich die Zeilen nun anpassen. Für xampp war das so richtig.

die Datenbank liegt in mysql-data und hat überraschende weise einen Namen der etwas von heisse-fantasien abweicht. Das muss wohl mal von Phpmyadmin so gemacht worden sein. Ich kann dazu keinen Grund mehr erinnern. (heisse@002dfantasien)
 

m.scatello

Aktives Mitglied
15 Februar 2017
875
91
28
Dein Problem ist ein veraltetes Script, die mysql_*-Funktionen sollten schon lange nicht mehr benutzt werden. Benutze statt dessen die mysqli_*Funktionen oder PDO.

Achte auf die Warnung: http://de2.php.net/manual/de/function.mysql-connect.php

PS: Wenn man deinem Link (pc-easy) folgt, bekommt man:
Als attackierend gemeldete Webseite!

Die Webseite auf www.alice-dsl.net wurde als attackierende Seite gemeldet und auf Grund Ihrer Sicherheitseinstellungen blockiert.

Attackierende Webseiten versuchen, Programme zu installieren, die private Informationen stehlen, Ihren Computer verwenden, um andere zu attackieren, oder Ihr System beschädigen.

Manche Webseiten vertreiben bewusst Viren und ähnlich schädliche Software, aber viele Webseiten sind auch ohne das Wissen oder die Erlaubnis des Betreibers kompromittiert.
 
Zuletzt bearbeitet:

Industriemeister

Mitglied
24 Februar 2011
469
1
18
www.heisse-fantasien.de
Hallo danke für den Link und den Hinweis um den ich mich aber später kümmere.

Erst einmal: verstehe ich den Link richtig anstatt mysql... heisst es nun immer mysqli....
Also habe ich die Zeilen entsprechend geändert
// Datenbank OFFLINE
mysqli_connect("127.0.0.1","root","") or die ("keine Verbindung moeglich");
mysqli_select_db("heisse-fantasien") or die ("Die Datenbank existiert nicht");
?>

Doch ich bekomme noch immer eine Warnung. Apache läuft. MariaDB kann ich nicht finden.
Aber wenn ich das richtig sehe brauche ich MariaDB nicht?
Die Datenbank liegt ja in mysql-data also für phpmyadmin / mysql oder hat sich da auch was geändert?

Warning: mysqli_connect(): (HY000/2002): Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte. in C:\webserver\htdocs\heisse-fantasien\dbconnect.php on line 6
keine Verbindung moeglich
 

Industriemeister

Mitglied
24 Februar 2011
469
1
18
www.heisse-fantasien.de
OK,

dann habe ich vielleicht zwei Probleme.
Zum einen die Fehlermeldung oben.
Zum anderen finde ich nämlich MariaDB nicht im TaskManger.
Die Codes in den MariaDB_istall... und MariaDB...start entsprechen jedoch dem was Du in den Codeschnippsel gepostet hast.
 

m.scatello

Aktives Mitglied
15 Februar 2017
875
91
28
Im Taskmanager findest du auch kein MariaDB, denn das Executable heißt auch bei MariaDB mysqld.exe

Guck mal unter den Diensten, ob MariaDB installiert ist und ausgeführt wird.
 

m.scatello

Aktives Mitglied
15 Februar 2017
875
91
28
Dann nochmal MariaDB_Install_as_service.bat starten und gucken, ob es eine Fehlermeldung gibt. Achte darauf, dass in der letzten Zeile ein pause steht, sonst siehst du keine eventuelle Fehlermeldung.

Etwas mehr Wissen in Sachen Windows und Programmen bzw. Diensten sollte man schon haben. Nur mit der Maus rumklicken ist selbst bei Windows nicht immer der Fall.
 

Industriemeister

Mitglied
24 Februar 2011
469
1
18
www.heisse-fantasien.de
Die Zeile Pause hatte ich schon eingefügt.
Und vor und nach der Eingabe die Pause hervorruft habe ich keine Fehlermeldung gesehen.

folgendes wird in der cmd.exe geschrieben
"Installiere MaraidB als Dienst"
2017-09-10 13:16:59 3488 [note] C:\webserver\mariadb-10.2.8-winx64\bin\mysqld <mysqld 10.2.8-MariaDB> starting as process 5024 ...
Drücken Seie eine beliebige Taste ...

nach drücken einer Taste schließt das Ausführungsfenster
 

m.scatello

Aktives Mitglied
15 Februar 2017
875
91
28
Ähmmm, sorry, die Batchfiles habe ich noch nicht wirklich getestet, hier eine Korrektur:
Code:
@ECHO off
REM
REM MariaDB_Install_as_service.bat
REM
echo "Installiere MariaDB als Dienst"
C:\webserver\mariadb-10.2.8-winx64\bin\mysqld --install MariaDB --defaults-file="C:\webserver\mariadb-10.2.8-winx64\my-large.ini"
pause
 
Werbung: