XAMPP: php_ssh2.dll is not a valid Win32 application.

  • Jetzt anmelden. Es dauert nur 2 Minuten und ist kostenlos!

nookie

I did it all for the nookie
14 Mai 2013
1.404
251
83
www.ebookempfehlung.de
Hallo zusammen,

kurz gefasst habe ich XAMPP mit PHP 7.2 auf meinem neuen Rechner installiert und dazu alle anderen Erweiterungen die ich bei PHP benötige. Doch bei der php_ssh2.dll tritt folgender Fehler auf: ".. is not a valid Win32 application.". Eindeutig oder? Nun, habe ich schon alle möglichen Versionen ausprobiert aber bin noch zu keiner Lösung gekommen.

Danke im vorraus.

LG
 

m.scatello

Aktives Mitglied
15 Februar 2017
880
92
28
Die API-* kannst du vergessen, aber bei libeay32.dll scheint was nicht zu stimmen und die PHP5TS.dll scheint auch zu fehlen bzw. ist nicht im Pfad
 

m.scatello

Aktives Mitglied
15 Februar 2017
880
92
28
Die MSVCRT.dll und die KERNEL32.dll sind eigentlich Dll's, die im System vorhanden sein sollten.

Sind in XAMPP eigentlich Apache und PHP in der 64 bit Version drin?
 
Zuletzt bearbeitet:

nookie

I did it all for the nookie
14 Mai 2013
1.404
251
83
www.ebookempfehlung.de
Ja in der 64 Bit Version. Und ja die zwei DLL's sind vorhanden, deswegen ist es ja irgendwie komisch. Konnte das Problem bisher nicht lösen und bin kurz davor XAMPP wieder downzugraden.
 

m.scatello

Aktives Mitglied
15 Februar 2017
880
92
28
XAMPP nutze ich schon lange nicht mehr, deswegen kann ich dir nicht weiterhelfen. Ich habe mir den Apache, PHP und MariaDB einzeln installiert, den ganzen Schlamm, den XAMPP noch mit sich bringt, brauche ich nicht.
 
Reactions: nookie

m.scatello

Aktives Mitglied
15 Februar 2017
880
92
28
Habe das gerade mal bei mir ausprobiert:

PHP Warning: PHP Startup: Unable to load dynamic library 'ssh2' (tried: C:\webserver\php-7.2.0\ext\ssh2 (Das angegebene Modul wurde nicht gefunden.
), C:\webserver\php-7.2.0\ext\php_ssh2.dll (Die angegebene Prozedur wurde nicht gefunden.
)

Klappt also bei mir auch nicht

Nachtrag:
Mit PHP 5.6.31 x64 klappt es bei mir. Scheint wohl die Dll für PHP 7.2.0 x64 nicht ok zu sein
 
Zuletzt bearbeitet:
Werbung: