Problem mit dem Heimverzeichnis

  • Jetzt anmelden. Es dauert nur 2 Minuten und ist kostenlos!
12 Mai 2017
144
2
18
#1
Hallo,

ich bin immer noch dabei, das Laravel-Projekt online zu stellen auf bplaced (als Übung). Ich habe da aber ein Problem. Das www Verzeichnis ist das Heimverzeichnis. In diesem habe ich eine index.php erstellt, die auf die Index-Datei im Public-Verzeichnis des Projekts referiert: projektname->public. Das Problem ist jetzt, dass in der URL nicht mehr nur die Domain zu sehen ist, sondern auch das Verzeichnis, indem wir uns befinden: bplaced.net/projektname/public. Alle weiteren Links funktionieren also nicht mehr, beispielsweise funktioniert bplaced.net/projektname/public/musics anstelle von bplaced.net/musics, was so nicht sein sollte. Das heißt, dass ich die Namen aller routes um projektname/public/ erweitern müsste, aber das wäre doch einfach nur zeitaufwändig. Könnte ich das Heimverzeichnis ändern, wäre das Problem gelöst, aber ich finde keine Option auf bplaced, um das zu tun. Bleibt mir nichts anderes übrig als die Namen aller routes zu verändern?

LG
 

basti1012

Aktives Mitglied
26 November 2017
736
69
28
37
Minden
chat.sebastian1012.bplaced.net
#2
So ganz verstehe ich das nicht .Ich habe auch bpaced und habe keine probleme.
Die index Datei kommt in den "www" Ordner,das hast du ja. Alle weiteren Datein die du auch in den "www" Ordner rein tust ,haben dann den Link "deineseite.bplaced.net/irgendwas.html"
Wenn du dann in den "www" Ordner noch ein Ordner hast mit den Namen "projekt" dann ist der Link in den Ordner ja "deineseite.bplaced.net/projekt/irgendwas.html"
Man kann die einzelne Ordner mit der .htaccess Datei irgendwie ausblenden ,aber das weiß ich nicht wie genau.

Fals ich dich irgendwie Falsch verstanden habe dann erklär das bitte nochmal ,notfals mit Link zur Seite damit man mal sehen kann was du genau meinst
 
12 Mai 2017
144
2
18
#4
Danke euch beiden für die Antworten. Ich habe einfach eine Subdomain erstellt, bei der das Hauptverzeichnis der Public Ordner ist - so klappts auch :)