Frage 2 jQuery Versionen abrufen - noConflict

  • Jetzt anmelden. Es dauert nur 2 Minuten und ist kostenlos!

priinzii

Neues Mitglied
22 Februar 2019
17
0
1
23
Nabend!

Ich weiß, dass es nicht die sauberste Lösung ist, aber ich möchte gerne 2 verschiedene jQuery Versionen in meine Webseite einbauen.
Dafür möchte ich gerne die noConflict Methode verwenden. Bloßes einfügen des Codes unter der Einbindung des jeweiligen Scripts hat allerdings nicht gereicht. Auch nach Anpassung der Kennzeichnung noch nicht.

5105


Muss ich etwas im Script anpassen? Bin dort nicht sonderlich erfahren.

Würde mich sehr über Hilfe freuen.

Liebe grüße und schönen Start in die neue Woche.
 

Aaron3219

Senior HTML'ler
6 Oktober 2015
1.017
200
63
17
Dürfte ich den Grund für deinen (imo sehr unsauberen) Ansatz erfahren?
 

basti1012

Aktives Mitglied
26 November 2017
760
70
28
38
Minden
sebastian1012.bplaced.net
hast du mal einen beispiel code wofür du das brauchst ? Wozu brauchst du den überhaupt eine alte Version ? Weil es gibt ja fast für jeden veralteten code auch was neues.
Vieleicht kann man dir auch so helfen ohne beide versionen einbinden zu müssen.
 

priinzii

Neues Mitglied
22 Februar 2019
17
0
1
23
Dürfte ich den Grund für deinen (imo sehr unsauberen) Ansatz erfahren?
hast du mal einen beispiel code wofür du das brauchst ? Wozu brauchst du den überhaupt eine alte Version ? Weil es gibt ja fast für jeden veralteten code auch was neues.
Vieleicht kann man dir auch so helfen ohne beide versionen einbinden zu müssen.

Ehrlich gesagt sehe ich mich nicht in der Lage ein komplettes Script neu einzubauen. Da werde ich mehr zerstören.

Es geht dabei um folgende Seite:

http://www.designjh.de/projektplaner.html

Code:
<!-------------------------------------------------- END FOOTER ---------------------------------------------------->
        
                  
                <!---------------------- SCROLL BUTTON ---------------------->
                  
                  <a href="#" id="scroll-top" class="fadeInRight animate-me"><i class="fa fa-angle-double-up"></i></a></div>

  
  
                <!------------------------- SCRIPTS ------------------------->


                <!--------------------------PLANER--------------------------->

                <script type="text/javascript" src="form/js/jquery.min.js"></script>
                <script type="text/javascript" src="form/js/bootstrap.min.js"></script>
                <script type="text/javascript" src="form/js/jquery.placeholder.js"></script>
                <script type="text/javascript" src="form/js/datetimepicker.min.js"></script>
                <script type="text/javascript" src="form/js/aquaria.form.js"></script>
              
                <!----------------------------------------------------------->
  
                <script src="js/jquery-1.11.1.min.js"></script>
                <script src="js/plugins.js"></script>
                <script type="text/javascript">
              
                        /*TEXT TICKER // STARTSEITE*/
                        $('#ticker-text').vTicker('init', {
                        speed: 300,
                        pause: 2000
                        });
              
                </script> 
  
                <script src="js/custom.js"></script>
                <script src="owl-carousel/owl.carousel.js"></script>
              
                <script>
                        $(function () {
                        $('#SkillsTab a').click(function (e) {
                        e.preventDefault()
                        $(this).tab('show')
                        });
                        });
                </script>
  

                <script>
                        $(document).ready(function() {
  
                        $("#owl-demo").owlCarousel({
  
                        autoPlay: 3000, //Set AutoPlay to 3 seconds
  
                        items : 3,
                        itemsDesktop : [1199,3],
                        itemsDesktopSmall : [979,3]
                        });
                        });


                </script>
 

priinzii

Neues Mitglied
22 Februar 2019
17
0
1
23
Also ich habe mit einem Generator ein Formular erstellt. Dieser verwendet Scripts die noch eine ältere jQuery Version verwenden.
 

Aaron3219

Senior HTML'ler
6 Oktober 2015
1.017
200
63
17
Also ich habe mit einem Generator ein Formular erstellt. Dieser verwendet Scripts die noch eine ältere jQuery Version verwenden.
Oh Gott... okay folgendes:
Dein Lösungsansatz ist hier absolut nicht sauber und ich rate dir dringend davon ab. Beschäftige dich stattdessen mit JQuery und lerne, wie du dein Vorhaben selbst in die Tat umsetzen kannst, denn Generatoren sind definitiv keine gute Lösung.
 
Reactions: priinzii

priinzii

Neues Mitglied
22 Februar 2019
17
0
1
23
Oh Gott... okay folgendes:
Dein Lösungsansatz ist hier absolut nicht sauber und ich rate dir dringend davon ab. Beschäftige dich stattdessen mit JQuery und lerne, wie du dein Vorhaben selbst in die Tat umsetzen kannst, denn Generatoren sind definitiv keine gute Lösung.
Also das was dabei herauskam sieht eigentlich ganz gut aus.Ich weiß nicht, ob sich der Zeitaufwand für so eine "Kleinigkeit" wirklich rentieren würde
 

Aaron3219

Senior HTML'ler
6 Oktober 2015
1.017
200
63
17
Also ich gehe mal davon aus, dass du in Zukunft mehr mit Web Development machen willst. In diesem Falle ist JQuery mandatory! Falls nicht, dann suche nach einem aktuellen Script, dass auch mit neuen JQuery-Versionen funktioniert. In der Regel müssen solche Scripte schon ziemlich alt sein, damit sie nicht mehr funktionieren. Auf GitHub wirst du da 100% fündig.
 

priinzii

Neues Mitglied
22 Februar 2019
17
0
1
23
Also ich gehe mal davon aus, dass du in Zukunft mehr mit Web Development machen willst. In diesem Falle ist JQuery mandatory! Falls nicht, dann suche nach einem aktuellen Script, dass auch mit neuen JQuery-Versionen funktioniert. In der Regel müssen solche Scripte schon ziemlich alt sein, damit sie nicht mehr funktionieren. Auf GitHub wirst du da 100% fündig.
Naja ich bin Designer. Ich bin für das äußerliche zuständig. Angebotenes Webdesign läuft über Kontakte. Webseite muss ich aber selber hinbekommen.

Ich kann absolut verstehen, dass du mir davon abrätst. Gibt es denn vielleicht noch eine andere Möglichkeit?
 

priinzii

Neues Mitglied
22 Februar 2019
17
0
1
23
Also ich gehe mal davon aus, dass du in Zukunft mehr mit Web Development machen willst. In diesem Falle ist JQuery mandatory! Falls nicht, dann suche nach einem aktuellen Script, dass auch mit neuen JQuery-Versionen funktioniert. In der Regel müssen solche Scripte schon ziemlich alt sein, damit sie nicht mehr funktionieren. Auf GitHub wirst du da 100% fündig.
Machst du das auch gewerblich?
 

Aaron3219

Senior HTML'ler
6 Oktober 2015
1.017
200
63
17
Du könntest mal in der Jobbörse nachfragen. Ich werde es aber nicht machen. Wenn sich da keiner meldet schauen wir mal weiter.
 
Werbung:

Latest posts