[ERLEDIGT] [(X)HTML-Validator] Was bedeutet dieser Error ?

  • Jetzt anmelden. Es dauert nur 2 Minuten und ist kostenlos!
Status
Für weitere Antworten geschlossen.
E

Efchen

Guest
URI zu dem Ergebnis geht glaub ich nicht da ich immer die *.html Datei vom Rechner hochlade und kein URI ausgegeben wird.
Ja nee, is klar. Aber deswegen muss man sie halt irgendwohin - im Zweifelsfalle auf einen kostenlosen Hoster - hochladen, damit einem besser geholfen werden kann.

Jedenfalls ist das dann in dem Buch Falsch beschrieben worden.
Dann schmeiß es gleich weg :-)
Wenn da auch drinsteht, dass man Lyout mit Tabellen macht, dann solltest Du es sogar gleich verbrennen!

Aber das Funktioniert auch nicht richtig weil es dann so aussieht.
HTML hat prinzipiell erstmal nichts mit dem Aussehen zu tun, weil hier nur die logische Struktur definiert wird. Aussehen wird allein mit CSS gemacht.

Aber Dein Screenshot bringt mir nichts ohne den dazugehörigen Code. Besser ist - wie schon gesagt - ein Link zur Seite.

mit der nicht validen Version also ohne die <li> wird es im Firefox richtig angezeigt ist aber nicht valide dann so rum ist es valide wird aber falsch angezeigt.
Du wirst womöglich noch einen anderen Fehler machen, z.B. das <li> in dem das <ul> liegt, leer zu lassen. Dann steht natürlich hinter dem Kästchen auch nichts.

Sieht Dein Code so aus?
Code:
<ul>
  <li>Eine DFÜ Verbindung</li>
  <li><ul>
         <li>DSL</li>
         <li>ISDN</li>
...
Es muss natürlich so sein:
Code:
<ul>
  <li>Eine DFÜ Verbindung
      <ul>
         <li>DSL</li>
         <li>ISDN</li>
...
      </ul>
  </li>
...
 
E

Efchen

Guest
Oder englisch lernen, HTML lernen und den Fehlerhinweis verstehen :-)
Es gibt keine Entity &gid;
Was Entities sind, ist Basis-HTML-Wissen. Also lieber schnell bei SelfHTML nachsehen und nicht posten "Was sind Entities?" ;-)
 

Hazelnut

Neues Mitglied
16 Juni 2010
31
0
0
www.welitso.de
Hallo:
Code:
[I]Line 11, Column 50[/I]: Bad value Language for attribute http-equiv on  element meta.      <meta http-equiv="Language" content="de-DE" /[B]>[/B]
Ich weis absolut nicht was daran falsch sein soll...
 
Zuletzt bearbeitet:

DasBaum

Neues Mitglied
6 August 2010
3
0
0
Hallo,

The Content-Language state is obsolete. Consider specifying the language on the root element instead.
<meta http-equiv="content-language" content="de">
Geht um HTML5.
Ja, was ist denn mit dem root element gemeint und wie ändere ich das?

Grüße
 

Basti225

Neues Mitglied
6 März 2010
113
0
0
www.tunetek.de.tl
Hallo,
habe einen Fehler den ich i.wie nicht verstehe :D
Ist ein HTML5 Dokument

Da steht:
Element xmp not allowed as child of element div in this context. (Suppressing further errors from this subtree.)
<xmp><a class="greybutton" href="URL">TEXT</a></xmp>

Kann mir jmd. sagen was ich falsch mache?!
 

Basti225

Neues Mitglied
6 März 2010
113
0
0
www.tunetek.de.tl
Und wie bekomm ich das hin?!
Also das der XMP Tag in einer ID ist?
Noch hab ich es so stehen:
HTML:
<div id="content">
<xmp>...</xmp>
</div>
Und wie bekomm ich das hin, das es nicht mehr <div id="content"> heißt?!
 

Basti225

Neues Mitglied
6 März 2010
113
0
0
www.tunetek.de.tl
Ich hab ja einen Content wo alle Inhalte Inhalte wie z.b. Texte und Bilder drinne sind.
Und dann ist da ein xmp Tag.
Also nicht der XMP Tag soll die ID Content bekommen sonder der ist in der ID.
Hmmpf, ich werd mal nach einer andere Lösung suchen
trotzdem danke ;)
 

Basti225

Neues Mitglied
6 März 2010
113
0
0
www.tunetek.de.tl
Hey,
ich check i.wie nicht was ich bei der Warnung machen soll o_O

Code:
Using experimental feature: HTML5 Conformance Checker.

The validator checked your document with an experimental feature: HTML5 Conformance Checker. This feature has been made available for your convenience, but be aware that it may be unreliable, or not perfectly up to date with the latest development of some cutting-edge technologies. If you find any issues with this feature, please report them. Thank you.

was da jmd weiter o_O
Gruß Basti
 
C

Commodore

Guest
Das bedeutet, dass dein Dokument zusaetzlich auf HTML5 Konformitaet geprueft wurde. Laut der Meldung ist dieser Check allerdings noch in der experimentellen Phase und daher unter Umstaenden nicht auf dem neusten Stand bzw. nicht perfekt funktionierend.
 

Daniel2112

Neues Mitglied
25 August 2010
3
0
0
Hallo da dies mein erster Beitrag ist,
sage ich erstmal Hallo an alle.

Ich bastel grade an meiner ersten Webseite und bin soweit ganz gut unterwegs. Sie läuft auf allen Browsern aber die Validierung macht mich fertig. Ich lese grade erst an die zwei Wochen über HTML und CSS und Fehler sind für mich sehr schwer zu finden.

Ich habe jetzt 3 Errors und 3 Warnings. Weiss aber nicht wie ich diese weg bekomme.

Mein Quelltext is dieser :
Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
       "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Page</title>

<link rel="stylesheet" href="css/style.css" type="text/css" media="all" > 



</head>
<body> 
<div id="container">      


<a href="index.html" target="_blank"> 
<img id="flaggede" src="bilder/de.gif"></a>
<a href="indexE.html" target="_blank"> 
<img id="flaggeE" src="bilder/gb.gif"></a>

<a id="link" href="index.html"> Startseite </a> 

<a id="link2" href="news.html"> News </a> 

<a id="link1" href="turnierbaum.html"> Turnierbaum </a> 

<a id="teams" href="teams.html"> Teams </a> 

<a id="forum" href="forum.html"> Forum </a>  

<a id="kontakt" href="kontakt.html"> Kontakt </a>  

<a id="sponsoren" href="sponsoren.html"> Sponsoren </a> 

<a id="partnerseiten" href="partnerseiten.html"> Partner </a>

<a id="regelwerk" href="regelwerk.html"> Regelwerk </a>  


<img id="startseite" src="bilder/hauptbild.jpg" /img>


<div id="eins2"> Notiz </div>
<div id="eins1"> Links </div>


</div>

</body>
</html>

Fehler sind diese : Error :
Code:
Line 17, Column 39: required attribute "ALT" not specified 
<img id="flaggede" src="bilder/de.gif"></a>

Error :
Code:
 Line 19, Column 38: required attribute "ALT" not specified 
<img id="flaggeE" src="bilder/gb.gif"></a>

Warnung :
Code:
Line 40, Column 49: NET-enabling start-tag requires SHORTTAG YES 
<img id="startseite" src="bilder/hauptbild.jpg" /img>

Error :
Code:
Line 40, Column 49: required attribute "ALT" not specified 
<img id="startseite" src="bilder/hauptbild.jpg" /img>

Also er sagt 3 Errors 3 Warnings aber zeigt nur die an die ich geschrieben habe....
*seltsam*

Ich hoffe ihr könnt mir weiter helfen würde mich freuen.
Mfg Daniel

Ps : Dank diesem Thread konnte ich schon 4 Errors beheben:D
 

Körnerbrötchen

Aktives Mitglied
4 Juli 2006
1.557
15
38
/home/korny
www.theus.name
Hallo zurück und herzlich willkommen!
Code:
<img id="startseite" src="bilder/hauptbild.jpg" /img>
ist falsch. Ein image-tag geht so:
Code:
<img src="pfad/zum/bild.jpg" id="dieId" class="seineKlasse" alt="Alternativtext, der das Bild beschreibt" />
Das wäre so das wichtigste. src und alt sind zwingend! Der Alternativtext beschreibt das Bild, um es auch für Leute, die einen textbasierten Browser verwenden oder die, auf Grund einer Sehbehinderung, einen Screen-Reader verwenden, "nutzbar" zu machen.

Damit wären eigentlich deine beiden Probleme geklärt, denn bei drei deiner Fehler, ist es der Alt-tag, der fehlt. Und bei der Warnung ist das "img" am Ende des tags zu viel.

Viele Grüße

Achso: Um den Aufbau einer Seite nicht so ruckelnd zu gestalten, empfiehlt es sich Bildern die Attribute "height" und "width" mitzugeben, also z. B. so:
Code:
<img src="pfad/zum/Bild.jpg" alt="Der Alternativtext" width="300px" height="112px" />
Die width und height-Angaben sollten mit der Originalgröße übereinstimmen, um Qualitätsminderungen zu vermeiden und Bandbreite zu sparen.
 

Daniel2112

Neues Mitglied
25 August 2010
3
0
0
Vielen Dank für die schnelle Antwort . Das werde ich natürlich sofort testen.

Mfg Daniel ;Jump


Edit : Körnerbrötchen du hast wirklich was drauf !

Aber nun sind alle Errors weg dafür 5 Warnungen:shock:
Alle sehen so aus
Code:
NET-enabling start-tag requires SHORTTAG YES 
<img src="bilder/hauptbild.jpg" id="startseite" alt="Startseite" />

Muss ich mir um Warnungen Sorgen machen ? Möchte schon ne vernünftige Seite und hab auch vor mir genug Zeit zu lassen. Habe jetzt versucht da unten </img> abzuschliessen aber das mag er auch nicht.
 
Zuletzt bearbeitet:
Status
Für weitere Antworten geschlossen.