[ERLEDIGT] .htaccess Internal Server Error

  • Jetzt anmelden. Es dauert nur 2 Minuten und ist kostenlos!

Werbung

Jetzt auf elektrisches Fahren umstellen, Umwelt schonen und 1.500km kostenlosen Strom von Tesla bekommen. https://ts.la/carsten15473.

Katha

Neues Mitglied
8 November 2016
2
0
1
34
Hallo,

nun komme ich auch mit einem .htaccess - Problem um die Ecke. Ich hab schon im Forum gestöbert, aber keine Lösung für das Problem gefunden.

Ich hab auf meinem eigenen Webspace schon einen Verzeichnisschutz eingerichtet. Der funktioniert ohne Probleme. Nun wollte ich auch auf unserer Schulhomepage einen Verzeichnisschutz einrichten.

Dazu habe ich mich an diese Anleitung gehalten und auch den Passwortgenerator benutzt. (Ich hab nämlich keine Ahnung, was da drin stehen muss.) Den realtiven Pfad hab ich mich sicherheitshalber auch vom Provider nochmal nennen lassen. Der müsste also korrekt sein.
Dann hab ich eine .htaccess und eine .htpasswd-Datei erstellt und beide in das zu schützende Verzeichnis kopiert.
Rufe ich die Seite nun mit dem Browser auf, werde ich aufgefordert Benutzername und Passwort einzugeben. Mache ich das, erhalte ich die Fehlermeldung "Internal Server Error". Hat jemand eine Idee, woran es liegen könnte?

Lg
Katha
 

scbawik

Senior HTML'ler
14 Juli 2011
2.542
448
83
Hallo,

nun komme ich auch mit einem .htaccess - Problem um die Ecke. Ich hab schon im Forum gestöbert, aber keine Lösung für das Problem gefunden.

Ich hab auf meinem eigenen Webspace schon einen Verzeichnisschutz eingerichtet. Der funktioniert ohne Probleme. Nun wollte ich auch auf unserer Schulhomepage einen Verzeichnisschutz einrichten.

Dazu habe ich mich an diese Anleitung gehalten und auch den Passwortgenerator benutzt. (Ich hab nämlich keine Ahnung, was da drin stehen muss.) Den realtiven Pfad hab ich mich sicherheitshalber auch vom Provider nochmal nennen lassen. Der müsste also korrekt sein.
Dann hab ich eine .htaccess und eine .htpasswd-Datei erstellt und beide in das zu schützende Verzeichnis kopiert.
Rufe ich die Seite nun mit dem Browser auf, werde ich aufgefordert Benutzername und Passwort einzugeben. Mache ich das, erhalte ich die Fehlermeldung "Internal Server Error". Hat jemand eine Idee, woran es liegen könnte?

Lg
Katha
Hast du noch andere Angaben in der .htaccess?
 
F

felixprogram

Guest
Zeig uns mal den Inhalt der .htaccess via des [code] [/code]-BB-Codes.
Vielleicht ist ja dort ein Fehler enthalten
 

Katha

Neues Mitglied
8 November 2016
2
0
1
34
Danke an scabiwik. Sein Tipp, dass der relative Pfad nicht stimmen kann, war goldrichtig. Mit etwas probieren klappts jetzt!
 
Werbung: