Frage Das Dokument hat den Test nicht bestanden: W3C CSS Validator (Level 3) Direkter Link

  • Jetzt anmelden. Es dauert nur 2 Minuten und ist kostenlos!

BasREI

Neues Mitglied
14 September 2020
2
0
1
42
Hallo zusammen,
ich bin neu hier mein Name ist Bastian und ich habe ein Problem:wink:,
bin auch nicht sicher wo ich mit meinem Problem richtig bin.
leider kenne ich mich nur ein wenig mit der Materie aus, und bin alles andere wie ein Fachmann.
ich habe seit kurzer zeit richtig viele Fehler Meldung, die Seite wurde auf wp gemacht und liegt bei all-inkl. aufn ftp Server mit einer php Datenbank.
ich habe unten mal Bilder von verschiedenen Bereiche der Fehler Meldung beigefügt.
ich glaube das es was mit einem Darstellungs oder einem Optimierungs Tool zutun hat, ich habe schon mal alle plugins deaktiviert ,die Fehler werden dennoch angezeigt.
die Seite lauft ohne Probleme und wären es nur 50 oder 60 Fehler wäre es mir recht egal aber soviel kann ich nicht einfach ignorieren.
vielleicht ist es auch die Ladezeit der Seite.

vielen dank schonmal fürs anschauen.
 

Anhänge

  • Screenshot (3).png
    Screenshot (3).png
    525,3 KB · Aufrufe: 8
  • Screenshot (4).png
    Screenshot (4).png
    290,6 KB · Aufrufe: 8
  • Screenshot (5).png
    Screenshot (5).png
    510,7 KB · Aufrufe: 6
  • Screenshot (6).png
    Screenshot (6).png
    247,6 KB · Aufrufe: 5
  • Screenshot (7).png
    Screenshot (7).png
    474 KB · Aufrufe: 4

tk1234

Mitglied
2 September 2020
46
10
8
ich habe unten mal Bilder von verschiedenen Bereiche der Fehler Meldung beigefügt.
Fehlermeldungen sollten immer als Text eingefügt werden, niemals irgendwelche Screenshots davon. Auch in dem Fall fehlt nämlich im Posting das wichtigste: der eigentliche Code bzw. ein Verweis darauf. Da in den Screenshots aber die URL der Seite zu sehen war lies sie sich trotzdem anschauen:

ich glaube das es was mit einem Darstellungs oder einem Optimierungs Tool zutun hat, ich habe schon mal alle plugins deaktiviert ,die Fehler werden dennoch angezeigt.
Ich habe von Wordpress keine Ahnung und weiß auch nicht was du da für Plugins drin hast - aber das Ergebnis ist Schrott. Im HTML stehen knapp 900kB CSS (formatiert 32.000 Zeilen Code!), das hat da überhaupt nichts zu suchen. Zusammen mit den externen CSS-Dateien sind das über 1MB CSS-Code, ich würde sagen dass ist definitiv zu viel - und irgendwas scheint da auch nicht ganz rund zu laufen, die Seite braucht erstmal 4s bis überhaupt was passiert …

die Seite lauft ohne Probleme und wären es nur 50 oder 60 Fehler wäre es mir recht egal aber soviel kann ich nicht einfach ignorieren.
Auch 50-60 Fehler sind nicht zu tolerieren und müssen behoben werden. Viele Fehler kommen wohl daher dass der CSS-Validator keine custom properties unterstützt, trotzdem bleibt noch einiges übrig (doppelte oder leere Eigenschaften, ungültige Kombinationen (float bei display:inline)), auch der HTML-Code selbst enthält noch einige Fehler. Da du den Code wohl nicht selbst geschrieben hast lässt sich das wohl auch nicht so einfach beheben: da musst du dich an die Hersteller der verwendeten Software wenden, es wird wohl auf löschen, neu machen hinauslaufen (dabei darauf achten was man einbindet und nicht einfach alles was nicht bei drei auf den Bäumen ist).
 

BasREI

Neues Mitglied
14 September 2020
2
0
1
42
Hallo, ja vielen dank für die schnelle Antwort,
dann muss ich mal sehen wie es da weiter geht.